MiWiFi 使用WISP桥接模式

前言:直到目前小米仍未在其固件中添加WISP类型的桥接模式(20191201)

前提:因为要手动修改系统配置,需要路由器开启SSH功能

要使用WISP模式进行桥接重点需要修改 /etc/config/wireless /etc/config/network 两个文件

/etc/config/wireless 为无线功能配置文件
/etc/config/network 为网络配置文件

第一步先把路由器设置为中继模式,成功连接上级路由后,改回普通路由模式。

这一步之后上级路由器的SSID、WPA密码等信息会写入/etc/config/wireless,省下手打上级路由器Wi-Fi名、密码以及手打配置的麻烦

第二步编辑配置文件

首先在 /etc/config/wireless 找到包含上级路由器信息的config块如:

config wifi-iface
	option ifname 'apcli0'
	option network 'lan'
	option encryption 'WPA2PSK'
	option device 'mt7603e'
	option enctype 'AES'
	option scanifname 'wl1'
	option apcliband '2g'
	option key '上级路由器PSK'
	option mode 'sta'
	option ssid '上级路由器SSID'
	option disabled '1'

修改 network 为 wan
去掉 disable 行
因为已经成功连过,所以其余的配置都是正确的
改好如下

config wifi-iface
	option ifname 'apcli0'
	option network 'wan'
	option encryption 'WPA2PSK'
	option device 'mt7603e'
	option enctype 'AES'
	option scanifname 'wl1'
	option apcliband '2g'
	option key '上级路由器PSK'
	option mode 'sta'
	option ssid '上级路由器SSID'

/etc/config/network 为网络配置文件
找到

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1'
	option macaddr 'xx:xx:xx:xx:xx:xx'

加入一行 option type ‘bridge’
改好如下图

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option type 'bridge'

文件修改完成之后,重启即可联网,虽然主页面显示断开

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注